g7psz';?>

HOME / KC901 serial VNA

KC901s blown

By g7psz •  2017-05-12 17:10:51 •  301 clicks
After not using it for a month, I switched on my 901S to sweep for electrical interference to radio reception.
The batteries were flat, of course, but It sparked up fine with the external PSU and displayed the appropriate spectrum sweep. When I returned a short while later with a better pickup aerial, it had switched off and the case was unusually warm.
After a bit of preliminary fiddling with the power module, I decided I had to open it up. The LM2596 regulator chip and the inductor nearby were hot enough to burn my finger tip........
The thought of work on the device is daunting, but I have unsoldered the five leads to the SMD regulator and will try to replace it with a TO220 version (awaiting its arrival). If it works I will leave the old regulator still attached to the board by its heatsink and fabricate a heatsink bolted to the case for the new one.
If this does not work, I have a bricked 901S.
Has anyone else had a similar problem? Somewhat worrying, I wonder if the internal regulator can charge flat batteries and run the analyser at the same time (the internal cells were down to 3.3v but charged ok on a LiPo charger)?

Steve G7PSZ
10 Reply | until2017-11-19 14:47Add a reply
    BG8NPK  181 days ago#1 -Reply

    @g7psz

    Hi,
    Sorry for this dead cap that make your device down.
    We will check the element quantity and do more test in factor to improve the product.Also we are happy to see your instrument come back.

    Best Regards,
    WuXiao


    mjohnellis  183 days ago#2 -Reply

    Thank you for letting us know the problem. This kind of problem is very typical. I have fixed many products by looking for shorted caps - especially tantalum. Good job!


    g7psz  185 days ago#3 -Reply

    @g7psz
    Well, I got home and attacked the device again, having drawn a more logical "linear" simplified psu schematic.

    A few more surface mount components lifted, and lots of continuity tests later (to cut a long story short) I located tiny smd capacitor as shorted. On close inspection through a magnifying glass there as heat damage around it and tiny solder splatters on the board.

    The faulty capacitor was c54, 15uf which decouples the input to the 3v regulator, U8. This capacitor ia absolutely minute anss I made no attempt to replace it with my eyesight and relatively shakey hands. I can see no reason for using such a minute (and obviously inadequate) device. There is plenty of space to use a physically larger capacitor.

    I wonder if anyone else has had this one blow? Its failure caused a short circuit reading over large parts of the PSU board, and it was a bit of logical thought and redrawing the psu circuit which cracked it.

    The analyser is now reassembled (missing a fea smd caps) and seemingly working, so far. A celebratory bottle of wine is appropriately opened.

    One strange anomaly not solved and that is the isolation of the negative side of the battery pack. There must be an electronic switch somewhere not shown on the schematic. It is working on battery alone and apparently charging also.

    Happy days,
    G7PSZ.


    g7psz  186 days ago#4 -Reply

    My last reply seems to have got lost, so will type again.

    I am now away for a few days but I did make a little progress, thanks to the hi- res scematic of the power supply.

    I lifted d5 to isolate the 2596 first regulator and soldered the 2596 legs back onto the board. It worked fine giving 11v no load.

    Downstream was a complete ohmic short (0.0 ohm). Next task will be to lift c23and c28. If those are not shorted, I will have to lift d15.

    One other separate problem is the battery pack. The negative (ground) shows MINUS 8v to ground. When the batteries are removed there is an open circuit between the battery neg and ground. Is there a battery fuse somewhere? I have taken the whole psu board out of the case and cannot see one anywhere.

    Steve G7PSZ


    g7psz  187 days ago#5 -Reply

    Thankyou for the full-res psu schematic.

    I have done a bit more investigation before I had to go away for a few days.

    I lifted isolation diode d5, reconnected the regulator, and the whole circuit around LM2956 reg is working, giving about 11v unloaded.

    The circuitry downstream of D5 gives a dead short (0.0 ohm). Also the battery pack, with charged cells in the correct way round gives MINUS 8v on the neg (supposedly ground) side and 0v on the pos side, both with respect to ground. There is NO connection between the neg side of the battery pack and ground. Is there a small fuse link somewhere? I have now taken the board out of the case and cannot find one.

    Further investigation ( lifting c23and28, the two caps immediately downstream of d5, and if they are ok cutting the board to isolate the two branches of circuitry to see which has the dead short) will have to wait until I return.

    Thankyou again for your help.


    BG8NPK  190 days ago#6 -Reply


    mjohnellis  190 days ago#7 -Reply

    Since this is a step down dc to dc you may want to check the diode near the chip and the tantalum filter capacitor at the output of the inductor with an ohmmeter. If you're really want to see if it is working you could connect a temporary adjustable supply for the step down voltage, but you will have to remove any parts that appear shorted.


    g7psz  190 days ago#8 -Reply

    Thankyou.

    The psu schematic is very helpful but difficult to read because the pixel resolution is too low; is it possible to post again at a higher resolution?

    Anyway, I attacked the board again. A continuity check shows the regulator chip might be ok. The inductor is ok.

    However the regulated output pad on the board shows a low resistance to ground; the same with the ohm meter either way round. It just happens to be the same reading as a schottky diode in the forward state.

    Either the recovery diode is blown (I will lift and test) or something is a short downstream. I can only investigate that by powering from a bench psu with controlled voltage and current limits and sniffing for "warmth" around the board.

    Steve G7PSZ


    g7psz  191 days ago#9 -Reply

    Thankyou. I had not thought of a shorted cap. Yes, I had already disconnected the RF side and it still did not boot. I had done it for electrostatic safety while unsoldering the regulator. I inspected the ribbon connector for heat damage as well, as several amps must have been drawn -everything in the case, as well as the case was very warm.

    The postregulator caps are a long string of smds. Hmmmm. I will get cracking with the ohm meter.

    If I had to replace the whole device, I suppose I would upgrade to the 901V, although I have no interest above 1ghz. I would want it for its spectrum analyser resolution bandwidth, although I would rather it went down to 100hz, rather than 1khz minimum. I cannot see why a software upgrade could not sort this, as the lower bandwidths are apparently done with FFT software rather than physical filters.

    Steve, G7PSZ


    BG8NPK  191 days ago#10 -Reply

    Hi,

    This problem usually caused by a broken cap after the LM2596. maybe one cap was short to the ground and the LM2596 is strong that not easy to dead.

    First you can remove the RF module cable to disconnect the RF module and the control board, Then power one the instrument. If the KC901S can boot with only control board that mean the short point is in the RF module, that mean you can't fix out by yourself and you have to send this instrument back to the factor to fix. If KC901S can't boot even just the control board that mean the short pint may in the control board. you can try to find the short point and replace the element to fix.

    Usually we will use the Thermal imager to find the dead element...

    This is the sch of KC901S power circuit.



Reply

LoginPublish or Still no account?Register

Deepace-BBS

Theme List

KC901 serial VNA