RikiZampi';?>

HOME / KC901 serial VNA

Charging Problem

By RikiZampi •  2018-06-28 14:26:58 •  265 clicks
I am experiencing some problems charging my KC901S+,
I have tried a different power supply connector and nothing. LG batteries aren't recharging either.
Even when taking batteries out and the device is pulgged in and connected, not switching ON.

Help please.. I really love my VNA and I need it functioning asap
8 Reply | until2018-11-18 13:39Add a reply
    charli  129 days ago#1 -Reply

    Please open the picture.
    Forum members may give advice.


    RikiZampi  130 days ago#2 -Reply

    @BG8NPK Hi please, I really need to do something about it, I still have not received an email from your manager, and this is very urgent as I need this device for work.


    VK3NH  135 days ago#3 -Reply

    Your not the only one who cant get replies to emails.


    RikiZampi  137 days ago#4 -Reply

    Hi, this is urgent please, your manager has not yet contacted me


    RikiZampi  141 days ago#5 -Reply

    ricardozampetti@gmail.com


    BG8NPK  141 days ago#6 -Reply

    @RikiZampi

    Please give me your mail address and our manager will contact you to return


    RikiZampi  142 days ago#7 -Reply

    Hi, thanks ..

    No LED light.

    Not sure which one is the RST button but only little button I see is the CS. I have tried that, and still not functioning.

    I have tested the input fuse and it seems to be ok as well.

    I guess I have to send this back to you. How can we proceed on this please ?

    Regards


    BG8NPK  143 days ago#8 -Reply

    Hi,
    It maybe a hardware problem, when you open the KC901 and plug a power supply, is there any led light on?

    when you remove the batter and plug a supply, you can try press RST (the little button) it will work?

    If anything it not work, you may need to send the instrument back to us and we will do a warranty


Reply

LoginPublish or Still no account?Register

Deepace-BBS

Theme List

KC901 serial VNA